No PUSH notifications are received by ANY Android device -- Android App Opens ALL show "Opt-out opens"

We are adding an Android app to our existing UA App for iOS.

In the Android app, we have everything set up correctly, as far as we can tell. But, no PUSH notifications are being received.

Looking in Reports -> Unique App Opens -> Platform = Android

We can see that we are getting App Opens recorded by UA, but, all of them are shown as "Opt-out opens" and "Opt-in opens" are all ZERO.

We've checked on the test devices we are using, the Notifications checkbox in the Application Manager settings screen is checked on all devices.

We also tried adding: UAirship.shared().getPushManager().setUserNotificationsEnabled(true);

WHY are all our devices showing up in UA as Opt-Out? How do we get them to Opt-IN?

THANK YOU FOR YOUR HELP!

 

Didn't find what you were looking for?

New post

Comments

3 comments

  • The root issue was that the gcm library was not linked properly.


    Those who are currently experience a similar issue are encouraged to check their own FCM setup and to work through the documents linked in my previous reply.

  • To follow-up on my own question, further investigation has shown that we are not getting a registration token in the app when calling getRegistrationToken(). Maybe this is why all our devices appear as "opt-out"? Why are we not getting tokens??

    0
  • I responded in the support ticket you created since our forums are for our customers on our free ecommerce plans.

    But in case others are searching for a resolution for a similar issue, here is part of the response that was sent:

    It looks as though there are invalid GCM/FCM credentials that are being used. This can be tested by making an authentication request via Google's API endpoint: here. I tried using the credentials that were entered in the Urban Airship web dashboard (here) and it returned an InvalidRegistration error.

    Here is a document that can help troubleshoot this issue: GCM/FCM Troubleshooting Guide

     

    0

Please sign in to leave a comment.