Android SDK : Play services version 10.2.4 compatibility ?

Hello, 

We're using an old version of UA Android SDK (8.0.4) in our app which use the Play services 9.4.0. 

In our last release we have upgraded the Play services to 10.2.4, and the mismatch of version causes a "No such method in class gms/iid/MessengerCompat"

We would like to upgrade UA to the latest version 8.5.1 which come with 10.2.1 Play services version and exclude gcm and iid dependencies from UA and set theses ones to 10.2.4 in our app.

Before doing this I want to be sure that your SDK is compatible with the 10.2.4 version, regarding the Play services release note, it's just a one version bump and the add Firebase Cloud Storage feature, so I think it's ok, but I would like your advice on this one.

Thanks and have a good day.

Yohann

  

Didn't find what you were looking for?

New post

Comments

2 comments

  • There should be no issues with the case described here. As always, if there are any issues please do let us know so we can help you through them. Thanks!

    0
  • Thanks for you fast response. So I'm going to implement this solution and let you know if there are issues. 

    Thanks again. 

    0

Please sign in to leave a comment.