Community Forums

Where our customers, developers, and more can come together to help each other with both general and technical questions about our products and services.

Unable to update p12 Certificate

Lauren Silvers

Hi Team,

I am trying to update p12 certificate. I am sure its production certificate I checked everything and I tried with multiple choices like uploading only certificate, certificate with pin , and uploading development certificate too.I am getting same error that "You  uploaded development certificate for production app."

IOS Apple push service is about to expire in two days.Please help me in solving this issue. I do have enterprise membership.Awaiting for response.Thanks in Advance.


Please sign in to leave a comment.


Hi Team,

Thanks for responding ,but I cannot  find certificate with APNS push Certificate in production . I can find IOS Distribution and apple push cervices .I am tried exporting iOS distribution certificate in .p12 and uploading it to  urban airship.Is what am doing is wrong ?

 I even tried to download Apple push Service Certificate from developers portal.It is in .cer format. I exported the file from keychain access in .pem format and tried to upload it.It is still showing the same error.And I don't find any key associated with pem file.

Awaiting for your response.Thanks in advance.


Lauren Silvers 0 votes

My apologies but I'm a little confused by what you are referring to.

Is it step 2 in this doc where you are not seeing the option to select a production certification?

After going here: and choosing to add a certification, this is the option you are looking for:

Was this what you chose?

Referring to specific parts of the APNS setup doc linked previously and including screenshots may help

Mike Bedney 0 votes