Unable to add urbanairship-react-native to freshly detached Expo project (Expo SDK 25)

Specifically, I am unable to get iOS working. The urbanairship-react-native documentation states to add the AirshipKit SDK. I tried adding "!use_frameworks" in the Podfile but that interferes with ExpoKit dependencies. I also tried adding AirshipKit manually, but then get errors about how some method(s) or file(s) cannot be found.


1st error type:

'React/RCTEventEmitter.h' file not found

(within UARCTEventEmitter.h)


2nd error type:

No known class method for selector 'messageCenter'

(within UARCTMessageCenter.m)



Didn't find what you were looking for?

New post




    we've ran into the same issue, and was able to resolve it with 

    pod 'UrbanAirship-iOS-SDK', '~>9.0'

    make sure you've update your pod repo to install this

    Comment actions Permalink
  • Hi

    I'm running into same issue with pod 'UrbanAirship-iOS-SDK', '~>9.0'


    Were you able to resolve this?

    Comment actions Permalink

Please sign in to leave a comment.