Crash on iPad 2,3,4 devices 32 bit when open app

i'm using objective C to developed and have released many versions app on apple store. 
And now have problem with my app.
Before yesterday app have run without any problem, and from yesterday i don't know why i try to open app from screen then app has crashed.
But this problem has opened only iPad 2,3,4 and i also tried on iPad air (1,2) but it wasn't crash.
So please help me.

Didn't find what you were looking for?

New post



  • Hi,

    I'd be happy to help. Can you please provide some additional information:

    1. What is the version of iOS on these devices?
    2. What version of the Urban Airship SDK are you currently using in the app?
    3. Please provide any crash logs or console errors you are seeing in Xcode that are generated when the app crashes or before. 


    Jay M.
    Urban Airship Technical Support


    Comment actions Permalink
  • I got it.
    Thank you so much for your support.

    Comment actions Permalink
  • iPad 2,3,4: iOS 10,
    and urban airship: libUAirship-6.4.0
    The log crash i got through fabric.
    As from 03/07 my app has got a lots crash report from fabric. But i don't change anything about urban airship.

    I have checked sometimes, the crash has opened on 32bit devices as ipad 2,3,4, iphone 5,5c.
    And on 64bit devices don't crash.

    I have just updated to the newest urban aiship lib and then i haven't crash.

    So is have your change what is has problem with 32bit devices.

    Thank you and i looking for your forward. 

    Comment actions Permalink
  • Ok, a few things that might help diagnose further:

    1. If you are updating to the latest SDK (which is a good idea), make sure you review the migration guides, as you are updating from a very old version (from 2015). You can find those here.
    2. The crash logs from fabric might not be what we need. The ones from Xcode's console would likely be more informative as to which lines of the code is causing the crash. 
    3. 32 bit may or may not be the source of the crash, but it's worth mentioning that iOS dropped support for 32 bit in iOS 11, but since you are running iOS 10 and our latest SDK still supports iOS 8 and up, this should not be an issue. 
    4. Lastly, it's also possible the crash is not related to our SDK. Do you have other libraries in this project? This is why looking at the crash info would help narrow it down.

    Let me know.

    Jay M.
    Urban Airship Technical Support

    Comment actions Permalink
  • Thanks for your suggestion and response.
    I have connected devices to mac and tried to debug why my app has been crashed. But when i build app to devices through cable and debug mode it haven't crash anything. The crash only happen when i export ipa file and upload to store or diawi, and then install to devices.

    Comment actions Permalink
  • Thanks for the update. 

    If that is the case it is possible that the alternative installation is part of the issue.

    A good way to test this is to upload the app through Xcode to your developer account and download it through TestFlight. If it doesn't crash in that case, then it is likely the issue is not with the app/code itself. 

    Jay M.
    Urban Airship Technical Support

    Comment actions Permalink

Please sign in to leave a comment.