iOS apns p12 certificate invalid error


I have a APNS p12 certificate uploaded and was about to expire. I have renewed the certificate and uploaded it again. It was successfully uploaded and the push notifications were working. Later after a couple of days, the push notifications were not working. When I tried to upload the certificate again, it says the certificate is invalid. I tried to upload that many times but I get the same error. Could you help me out with this issue?

Thanks in advance.

Didn't find what you were looking for?

New post



  • Hi Prathap,

    In these situations, we recommend clearing out any previously created certificateRequest and p12 files and walking through the process again. Usually there has been a mixup between environments and an development or QA certificate has been uploaded in error. 

    See our APNS setup guide for a walkthrough of the setup.

    Comment actions Permalink
  • Hi Brian,

    Thanks for the response. I was actually able to the solve the issue by creating the certificate again and uploading it to Urban Airship. However, if the problem persists, I'll get back on this.

    Thanks much!

    Comment actions Permalink

Please sign in to leave a comment.