When will 'urbanairship-react-native' support for autolinking in React-Native >=0.60?
https://facebook.github.io/react-native/blog/2019/07/03/version-60#native-modules-are-now-autolinked
https://github.com/react-native-community/cli/blob/master/docs/autolinking.md

Didn't find what you were looking for?

New post

Comments

4 comments

  • I just confirmed that React-Native 0.60 and autolinking are supported now https://github.com/urbanairship/react-native-module.

    I noticed that the "Gettting Started" page in the React-Native docs do explain installation for React-Native 0.60 because it says to run `react-native link`. 
    https://docs.airship.com/platform/react-native/getting-started/
    When will the React-Native docs for Urban Airship get updated?

    Comment actions Permalink
    0
  • Thank you for bringing this to our attention, Kevin. I'm glad you were able to confirm React Native 0.60 and autolinking are supported.

    I'm currently working with our Documentation Team to update the React Native Getting Started guide and can let you know once the update is live.

    Comment actions Permalink
    0
  • Thank you for your quick response. That is great!
    Please keep me posted on the update of the docs for React Native.

    Comment actions Permalink
    0
  • Hi Kevin. The React Native Getting Started Guide has been updated.

    Comment actions Permalink
    0

Please sign in to leave a comment.