Hi, I'm trying to set tags via an integration with the Segment Airship Destination. I followed all of the instructions at https://docs.airship.com/partners/segment/. However I'm not seeing any of my custom tags when I go to Audience -> Segments -> Select Tag -> Segment Integration. Could you please help me figure out why my tags are missing?

I tried contacting Segment support, but they told me that the Airship destination is owned and maintained by Airship, not by Segment.

I'm not sure if this is my entire issue or just part of it, but I see in the request logs from Segment to Airship the message "Traits do not meet requirements to set tags". Full details below. Could you please explain what requirements are not met?

[ { "request": { "body": { "anonymousId": <Redacted>, "channel": "server", "context": { "app": { "build": "407", "name": "River", "namespace": "com.useriver.river", "version": "1.0.32" }, "device": { "adTrackingEnabled": true, "advertisingId": <Redacted>, "id": "<Redacted>, "manufacturer": "Apple", "model": "iPhone11,2", "type": "ios" }, "ip": "", "library": { "name": "analytics-ios", "version": "3.7.1" }, "locale": "en-US", "network": { "carrier": "Verizon", "cellular": false, "wifi": true }, "os": { "name": "iOS", "version": "13.4.1" }, "screen": { "height": 812, "width": 375 }, "timezone": "America/New_York", "traits": { "AF_af_message": "organic install", "AF_af_status": "Organic", "AF_install_time": "2020-05-11 20:54:32.888", "AF_is_first_launch": true, "anonymousId": <Redacted>, "app_installer": "testFlight", "environment": "prod", "maxVideoDuration": "21.0", "onboarding_style": "new", "push_notification_authorization_status": "authorized", "userId": <Redacted> } }, "integrations": { "Amplitude": { "session_id": "1589306301" }, "AppsFlyer": false }, "messageId": <Redacted>, "originalTimestamp": "2020-05-12T17:58:21.960Z", "projectId": "2Py9Jo3Wn3", "receivedAt": "2020-05-12T17:58:22.731Z", "sentAt": "2020-05-12T17:58:22.167Z", "timestamp": "2020-05-12T17:58:22.524Z", "traits": { "anonymousId": <Redacted>, "push_notification_authorization_status": "authorized", "userId": <Redacted> }, "type": "identify", "userId":<Redacted>, "version": 2, "writeKey": <Redacted> }, "header": { "Accept": "*/*", "Authorization": "<REDACTED>", "Content-Type": "application/json", "User-Agent": "Segment.io/1.0", "X-Segment-Settings": <Redacted> }, "method": "POST", "url": "https://ua-pint-segment-prod.appspot.com/v1/destination" }, "response": { "body": { "message": "Traits do not meet requirements to set tags" }, "header": { "Alt-Svc": "h3-27=\":443\"; ma=2592000,h3-25=\":443\"; ma=2592000,h3-Q050=\":443\"; ma=2592000,h3-Q049=\":443\"; ma=2592000,h3-Q048=\":443\"; ma=2592000,h3-Q046=\":443\"; ma=2592000,h3-Q043=\":443\"; ma=2592000,quic=\":443\"; ma=2592000; v=\"46,43\"", "Content-Length": "58", "Content-Type": "application/json", "Date": "Tue, 12 May 2020 17:58:23 GMT", "Server": "Google Frontend", "X-Cloud-Trace-Context": <Redacted> }, "status": 400 } } ]

Thank you!

Didn't find what you were looking for?

New post



  • Hello Zach,

    The named user must exist for tags to be set, integration does not create the named user so if the named user exists but the traits are empty or don't meet the true/false requirement, there are no tags to set.

    • The following situations will produce a "Traits do not meet requirements to set tags response":

      • Empty traits: "traits" : {}
      • Traits that do not contain any entries with true or false values

    Can you verify if any of the traits meet the above requirements?

    Thank you,

    Chilun Liu

    Airship Support 

    Comment actions Permalink
  • Hi Chilun,

    Thanks for getting back to me. I've set the named user, but I had been sending strings instead of booleans for some of my traits. I tried removing the strings for the trait values, and it appears that I'm no longer getting the intermittent errors.

    However, I'm still not seeing any traits in the Airship dashboard. Could you please help me figure out why the traits are still not working?



    Comment actions Permalink

Please sign in to leave a comment.