Urban Airship 4.0.0 incompatible with Xamarin.Forms 2.3.3.180

We are trying to test Urbanairship in our Xamarin.Forms project and we keep hitting a dependency error (See below)

The package installs fine on a test project that isn't using Xamarin.Forms

We are using Visual Studio 2015

 

Error Unable to resolve dependencies. 'Xamarin.Android.Support.v4 24.2.1' is not compatible with 'urbanairship 4.0.0 constraint: Xamarin.Android.Support.v4 (>= 24.2.1)', 'Xamarin.Android.Support.Animated.Vector.Drawable 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.Design 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.v7.AppCompat 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.v7.MediaRouter 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.v7.RecyclerView 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.Vector.Drawable 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Forms 2.3.3.180 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.GooglePlayServices.Basement 32.961.0 constraint: Xamarin.Android.Support.v4 (>= 24.2.1)'.

Didn't find what you were looking for?

New post

Comments

1 comment

  • Hi Charles,

    I believe the incompatibility comes as a result of the Android Support library. Currently, Urban Airship builds against version 25.0.1 currently.

    Until Xamarin Forms updates their compatibility to use the latest Android Support library, you may use earlier version of the Urban Airship Xamarin component. Version 3.1.1 should allow you to compile the project properly.

    Comment actions Permalink
    0

Please sign in to leave a comment.