UALib: Channel registration failed, will retry Android

I'm getting "channel registration failed error".

also: UALib: InboxJobHandler - User has not been created, canceling messages update

 

FCM messaging is working properly and tested it in Google's FCM website. Also verified that the gcmSender is set properly in the app and Server key is set in the site. I'm not receiving any push notifications. Also, the error console is literally empty while sending any push test.

Please help me.

UAShip SDK 8.3

 

Didn't find what you were looking for?

New post

Comments

7 comments

  • Hi Balamurugan,

    Can you confirm what App Key you're testing with?

    Typically when we see that no Channel ID is being registered, that might mean that GCM/FCM is not configured properly in your app. You may or may not see GCM errors in your logcat that would indicate this.

    Also, make sure your device is properly connected to the internet and the time & date of the device is correct. Sometimes, if the date and time is not set to be updated automatically, that can prevent services, such as Google Play and other internet services, to stop working.

    Either way, go ahead and let us know what App Key you're testing on, and if you can provide more detail around the logcat logs, that would be great! We can dig in from there to find out what the problem is.

    0
  • Hi Michael,

    Thanks for the reply.

    Here's my AppKey: tbTsb7MMSomHOIxPw_H_3A

    So, uninstalled and re-installed the app to see if it solves the issue. I got a connection refused error:

    Request - Request failed URL: https://device-api.urbanairship.com/api/channels/ method: POST
    java.net.ConnectException: failed to connect to device-api.urbanairship.com/127.0.0.1 (port 443): connect failed: ECONNREFUSED (Connection refused)

     

    I dug a little further and found this: the very first launch after a new install (or clear data) gave this connection refused error, any subsequent app launch gave the errors mentioned in the original post.

     

    This is the second app that I'm using with UAShip. I don't think date & time is an issue because the first app works fine in the same device. I should mention that the first app was done a while back with GCM and this second one is based on FCM.

    Thanks in advance!

    0
  • Balamurugan,

    So, based on that log, it appears that it's trying to talk to localhost?

    Have you modified anything in your app or the device to change the base URL?

    Or, are you using the Sample app provided with the SDK?

    Any information you can provide on your implementation of the SDK will help.

     

    0
  • No I'm not using a local host or modified the base URL. No sample app either.  I'm testing it on a real device with open internet connection. The thing is, the first app still works (the one set up with GCM) in the same device.

    I've used the SDK as mentioned in the Quick Start guide.  At the end of the quick start guide, the test push also doesn't work. The error console shows absolutely nothing when I send a push. So, makes it hard for me either to give you additional info.

    I've given the App Key earlier. Let me know if more info is needed.

    Thanks.

    0
  • Balamurugan,

    If you would, instead of integrating the SDK into your app via the QuickStart guide, would you please integrate the Android Sample app that comes as a part of the SDK?

    If you can reproduce that on the Sample app, that I'll have the last bit of information I'll need in order to be able to take it to our Engineering team to investigate.

    0
  • Yeah. I went ahead and tried the way it is implemented in the sample app. I'm getting the same error. :/

    0
  • Balamurugan,

    I see you used the same app key to test the Sample App.

    Would you mind instead creating a new app within the Urban Airship dashboard and use new credentials on that app? I have a feeling it might be a credentials problem.

    0

Please sign in to leave a comment.