Invalid Bundle Structure libUAirship During IOS Application submission to Apple Store

We had no issues while doing ad hoc deployment, but when validating the app for App Store submission, it throws below error:


iTunes Store operation failed.

Invalid Bundle Structure - The binary file 'Frameworks/AirshipKit.framework/AirshipResources.bundle/AirshipResources' is not permitted. Your app can’t contain standalone executables or libraries, other than a valid CFBundleExecutable of supported bundles. Refer to the Bundle Programming Guide at for information on the iOS app bundle structure.


Please advise the fix as we are running out of time




Didn't find what you were looking for?

New post



  • I have checked "Copy Bundle Resources" section in Build Phases settings as per the suggestion in other forums, there indeed was reference to the UrbanAirship framework which had got added automatically without us adding it there.

    I have removed it from this section and then rebuilt/archived the app. Have cleared Derived Data folder, but still get the same error.

    I have recorded a clipping of how exactly I am trying to add the UrbanAirship SDK to Xcode to share here in the forum, but can't see a provision to upload it.


    Comment actions Permalink
  • Hi Steve,

    Can you verify what version of our SDK is being used? Does this still persist after updating to the latest (currently 8.5.3)?

    Here is a link to the repo for quick reference:

    Comment actions Permalink

Please sign in to leave a comment.