Error when uploading the App to iTunes Connect

Hi,

I am trying to push my app to the iTunes Connect but whenever i try i get the error in the file.

How can I fix this?

 

Thanks,

Manuel




urbanairship_error.png

Didn't find what you were looking for?

New post

Comments

8 comments

  • Hello Manuel,

     

    It appears that we did have an issue with version 7.0.1of the iOS Urban Airship SDK AirshipKit.bundle containing the CFBundleExecutable key. We have released a fix for this issue in version 7.0.2 of the iOS SDK. Please go ahead and download and integrate this new version and let us know if that resolves your issue.

    Urban Airship iOS SDK

    0
  • Hi Michael,

    I now have build errors:

    ld: warning: ignoring file /path/to/project/iphoneos/AirshipKit.framework/AirshipKit, file was built for arm64 which is not the architecture being linked (armv7): /Users/manuel/Library/Developer/Xcode/DerivedData/Proejct-aaogwlootsyfcifbpidqgbmiuwuc/Build/Products/Release-iphoneos/AirshipKit.framework/AirshipKit

    Undefined symbols for architecture armv7:

      "_OBJC_CLASS_$_UAirship", referenced from:

          objc-class-ref in AppDelegate.o

    ld: symbol(s) not found for architecture armv7

    clang: error: linker command failed with exit code 1 (use -v to see invocation)

     

    I changed some of the settings in the Airshitkit.xcodeproject regarding the architectures and valid architectures to make it work.

    Thanks

    0
  • Hi Manuel,

     

    I'm also having the same issue. What architectures and valid architectures did you set it to make it work?

     

    Thanks!

    0
  • Hi Jimmy, 

    Attached is a screenshot of the configuration, let me know if that isn't enough.

    Thanks

    0
  • Hi Manuel,

    Thanks for the response, i think i have also tried that but it didn't work. We just updated to 7.1.0 version and implement it using static library.

     

    Thanks

    0
  • Jimmy,

    Just to clarify, you're having the same "Unexpected CFBundleExecutable Key" error when trying to push your app to iTunes, correct?

    It may also be beneficial to you to instead use the Embedded Framework method of integrating with the SDK if the static library method is giving you headaches.

    0
  • Hello Michael - I am the same error when doing an archive build:

    ld: warning: ignoring file /Users/xxx/Library/Developer/Xcode/DerivedData/MyFamily-afnzuhffgifrdhgzkmvxrwfvwdfc/Build/Intermediates/ArchiveIntermediates/MyFamily/BuildProductsPath/Release-iphoneos/AirshipKit.framework/AirshipKit, file was built for arm64 which is not the architecture being linked (armv7)

     

    I performed all of the above(cleaning derived data, changing the architectures/valid architectures build settings for the AirshipKit Xcode proj) but I still get the same error only when doing an archive. Any clues. thanks. 

    0
  • Hi Evan,

    Would you be able to let us know which version of the library you're using?

    0

Please sign in to leave a comment.