Custom .caf not playing when receive remote notifictation

I've implemented UAirship remote notifications a long time ago and everything works perfectly. Recently I tried to add a custom notification sound, the file follow Apple rules:

- .caf

- Linear PCM 16 bits big-endian signed integer, 2 channels, 44100 Hz.

-476KB

I'm sure the file is correctly attached to my project because it worked with local notifications, and if a see the file properties I can see that the target was set, and if I check the Project > Build Phases > Copy Bundle Resources, the file is there.

 

Before releasing my app, I tested this using the PHP Framework to send a push and it worked, but now on production it doesn't seems to work. 

Could this be a UAirship bug or Am I missing something here?

BTW: The custom sound isn't playing but the notification is arriving with the default sound.

I hope someone can help me.

 

Didn't find what you were looking for?

New post

Comments

2 comments

  • Hi Lucas,

    The best way to troubleshoot this issue will be to either attach the test device to Xcode and capture Xcode device logs, or enable Persistent Connection Logging on the device to check that the correct value is arriving on the device in the APS payload and that the app is able to find the sound resource that is expected.

    Please give that a shot and let us know how it goes. Thanks!

    0
  • My app was at version 1.4.1, and it was updated thru the App Store to 1.5.0, after that the default sound was being played.

    Just to try something, I deleted the app and reinstalled it from the App store. After that it worked, now the app is playing the custom sound.

    I don't understand why this happened, why I required to remove the app. I can't ask my users to delete the app and reinstall it to get the new sound.

     

    Any ideas, what could have caused this?

    0

Please sign in to leave a comment.