Invalid Bundle Structure

Hi there

We are getting an Invalid Bundle Structure error when submitting our app to the App Store. Three of us have all tried to do this on different machines on both xcode 7.3 and 8 (not on the same machine) but we all get the same error. In development, the app runs perfectly as expected and notifications work with no problems at all. It is very similar to this post:

https://support.urbanairship.com/hc/en-us/community/posts/208270503-Getting-Error-Invalid-Bundle-Structure-libUAirship-During-IOS-Application-submission-to-Apple-Store?input_string=Invalid%20Bundle%20Structure

However, I can confirm that the framework is not in the Copy Bundle Resources section. We have been trying this for a week now and we are desperately running out of time. We came to UA after using notifications from elsewhere and it is so much better, but we're going to have to drop it if we can't get this resolved. Any help would really be appreciated and lets hope it's something really really simple!

This is the error during the submission:



For info, if we remove UA, then everything is fine.

Many thanks,

Michael

Didn't find what you were looking for?

New post

Comments

2 comments

  • Can I just add, that after producing the archive and having a look in to it, there is an executable produced within the framework. This is the problem, but how do I change things to stop this?

    See this:

    0
  • Hi Michael!

    Could you confirm that you're building against the latest SDK?

    As of 7.0.2, we fixed an issue with submission concerning the Airship Bundle, but if you're seeing it on the newest SDK, let us know and we'll take a look!

    0

Please sign in to leave a comment.