UserNotifications.framework issue

I am getting the following build error after including the above mentioned Pod in my project.


clang: error: linker command failed with exit code 1 (use -v to see invocation)

ld: framework not found UserNotifications


My project is being built with an iOS8 minimum requirement.


Please advise.



Didn't find what you were looking for?

New post



  • After hours of trying, I have found a partial solution, which includes reducing the version that's loaded with the pod.

    pod 'UrbanAirship-iOS-SDK', ~ 7.0.0''

    I assume that the latest version of the pod is using components from iOS10, but does not incidate so when the pod is being installed (which it should).

    I hope this will be corrected in the future.

    Kind regards,



    Comment actions Permalink
  • Armin,

    What xcode are you using? 8.0.0 requires Xcode 8.

    Comment actions Permalink
  • I'm using Xcode 7.3.1


    I suppose that explains the issue that I'm having. However, it's natural to expect that the pod will fail to install with a warning saying that the SDK version is not compatible with the current project or IDE.


    i.e. if you try to install the latest version of Alamofire within an iOS7 project, you will get an error saying that a minimum of iOS8 is required.


    Thanks for the update

    Comment actions Permalink
  • Armin,

    You are right, if a project requires a certain version of iOS, it will alert you to that fact.

    That does not apply to Xcode versions in this case.

    Xcode versions are not tied to iOS versions.

    Comment actions Permalink

Please sign in to leave a comment.